Jump to content

Can't insert Bet ID still

Recommended Posts


So recently I was aware that none of us were able to insert Bet IDs and it was stated in one of the weekly challenges too. However, I see that most people are now able to insert bet ids, but when I tried I still get this error. Does anyone else still get it, or is it just me? 


I tried the usual, signing in and out, clearing cookies and cache but it still seems to happen. 🤔

Share this post

Link to post
Share on other sites

To me it didn't work as well before, but as soon as I cleared the cache and cookies, it's working fine now. 

I don't know about yours since you already did that, maybe update your browser? 

Share this post

Link to post
Share on other sites
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.