Jump to content
UltraChief

Critial Bug in Electrum - Electrum users update right now!

Recommended Posts

This was posted on bitcointalk yesterday but its a very important piece of information about a vulnerability in Electrum which affects all versions below 3.0.3. theymos on bitcoin has made an announcement regarding it here:

https://bitcointalk.org/index.php?topic=2702103.0

If you use Electrum update it to the lastest version. Make sure to download it from electrum.org which is the official site and not any other site and verify the checksum before installing.

Update 1: If you had no wallet password set, then theft is trivial. If you had a somewhat-decent wallet password set, then it seems that an attacker could "only" get address/transaction info from your wallet and change your Electrum settings, the latter of which seems to me to have a high chance of being exploitable further. So if you had a wallet password set, you can reduce your panic by a few notches, but you should still treat this very seriously.

Update 2: Version 3.0.5 was just released, which further protects the component of Electrum which was previously vulnerable. It is not critically necessary to upgrade from 3.0.4 to 3.0.5, though upgrading would be a good idea. Also, I've heard some people saying that only versions 3.0.0-3.0.3 are affected, but this is absolutely wrong; all versions from 2.6 to 3.0.3 are affected by the vulnerability.

Update 3: You definitely should upgrade from 3.0.4 to 3.0.5, since 3.0.4 may still be vulnerable to some attacks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×